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BEFORE YOU START

1. Find the folder FileMaker Pro 2.1 Trial.  Open and double click on 
FileMaker Pro 2.1 Trial.  

2. Click on “Agree” for the license agreement.

3. Choose “Open” to open “Recycler’s Database.”

4. Switch to the Finder and double click to launch “Demo Helper.” 

5. Choose “Hide Others” from the Application menu at the top right on the menu bar.

6. The first time your mouse cursor goes over any of the colored buttons in Demo Helper, you will be asked 
to find the HyperCard 2.3 application. Do this. You will need to do this whenever the Demo Helper is 
restarted.

Demo Helper
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I . Introduction

A. Click on Intro  button in the 
Demo Helper.

B. Welcome to HyperCard 2.3 Demo.

C. What’s New? Brief picture and descriptive 
text for new features.

Click on  button.

1. Accelerated for Power Macintosh. 

Click on  button.

2. New Color Painting tools.

Click on  button.

3.  Automated button tasks.

Click on  button.

4.  Speak via Plaintalk.

Click on  button.

5.  Multimedia Utilities.
a. Morph.

Click on button.

E . Click on Basic  button in the 
Demo Helper.

Hi, welcome to HyperCard 2.3. Today, I’m going to 
demonstrate the latest version of HyperCard, especially 
focusing on all of the new features, which include: 

Acceleration for Power Macintosh — which greatly 
increases the performance of HyperCard for authoring 
and playback of stacks.

New color painting tools allow us to create and edit 24-
bit color images.

Button tasks allow us to automate many features of 
HyperCard, including playing movies, speaking text, 
navigating and more.

Support for Plaintalk gives our information a voice by 
speaking text from our HyperCard stack.

And a set of multimedia utilities which allow us to morph 
and edit QuickTime movies, as well as perform other 
media creation tasks.
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II. HyperCard Basics 

A. Show a typical stack.

Click on  button.

B. Show some buttons and fields.

Click on  button.

C. Explain card, stack metaphor.

Click on  button.

D. Cards tend to use same background.

Click on  button.

E. Cards are a composite of card 
and background layer. 

Click on  button.

F.  Stacks can contain pictures, movies, sound, 
speech as well as buttons and text. 

Click on button.

In this demo, we’ll cover the new features in depth as we 
explain all of the features of HyperCard.

First, let’s go through the HyperCard basics.
HyperCard is a do-it-yourself software construction tool 
for creating a wide range of Macintosh applications, 
including multimedia presentations, courseware, and 
computer-based training materials.

HyperCard organizes information into easy-to-use 
“stacks” of cards.  On each card you can have text, 
graphics, movies, sounds, and buttons.

Simply by clicking on a button, we can view related text, 
see a graphic, hear a sound, watch a QuickTime movie, 
or navigate to different cards in a stack.

The cards in a HyperCard stack are arranged in a circular 
fashion, so the first card in a stack and the last card in a 
stack are next to each other.

The cards within a stack are usually related to one 
another, or based on a common theme. They usually 
have the same look and contain similar information.

When we look at a card, we see a composite of two 
layers — a foreground layer, called the card layer, and a 
background layer.

Both layers can contain text, buttons, and graphics. 
Cards can also contain sound, animation and QuickTime 
movies.



III. Authoring Basics

A. Choose “New Stack…” from the File menu.

B. Choose card size “Classic."

C. Enter “Ways to Save the Earth” in the New 
stack name box.
1.  Click the “Desktop” button.
2.  Click the “New” button.

D. Create a new field by choosing “New Field” 
from the Objects menu.

1.  Select the Browse tool. 

2.  Click on the field and type Card 1 in it.

E. Choose “New Card” from the Edit menu.

F. Create a new field by choosing “New Field” 
from the Objects menu. 

1.  Select the Browse tool. 

2.  Click on the field and type “Card 2” in it.

G. Switch to card #1 by choosing “Back” from 
the “Go” menu.

Optional:  Click on 1  to catch up to 
this point if you need to; this may 
take up to 1 min).
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Now let’s look at some basics of authoring by creating a 
stack from scratch.  Let’s say you want to develop a 
stack that teaches young people about ways to help the 
environment. We want to include a section on recycling 
that illustrates what can be recycled and how to do it.

Creating a new stack is as simple as choosing a menu 
item and naming our stack.

Now we have a new stack with a blank card displayed. 
We can have a number of cards in our stack. Some will 
share the same background.

If we want to add another card, we open the edit menu 
and choose “New Card."  If we had any background 
elements, the new card would automatically acquire the 
background of the current card. 

When we add a new card to a stack, HyperCard always 
puts the new card right after the current card.

Now we want to create a section on glass recycling.  
Let’s add a color picture to the first card of our stack.
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H. Choose “Open Color Tools “ from the 
“Color” menu. 
1.  Click “OK” to dismiss any dialog. 

I. Choose “Place Picture…” from the 
Items menu.

1.  Click on the “Import…” button.

2.  Open “Recycling Glass.pict” from the 
“Content” folder on your hard drive.

3.  Click on  “Place.”

4.  Drag top left of picture to line up with 
top left of card.

J . Close coloring tools by clicking the close 
box on the coloring tools palette.

K. Tear off the tools menu by clicking on 
“Tools Menu,” holding and dragging.

L. Select the Field tool and click “Card 1” field. 
Drag it into the white box in the lower right 
corner of card.

M. Choose “New Button” from the 
Objects menu.

N. Double click the new button and choose 
‘Transparent’ from the Style pop-up menu.

1.  Turn off Show Name option by clicking 
it to deselect it.

2.  Click “OK.”

If you’re familiar with HyperCard 2.2, you’ll notice that 
the Color Tools Palette has changed to include the new 
color painting tools. We’ll show how these work later on 
in the demo.

Choosing “Place Picture” from the Items menu lets us 
import a color PICT into the HyperCard stack.

Buttons are “hot spots” we click on to make things 
happen in stacks. A button can take us to another card, 
show us a picture, launch an application, or play a 
QuickTime movie.

To work with buttons, we need the Button tool and the 
Browse tool.

To make it easy to alternate between tools, we can “tear 
off” the tools menu to create a movable tool palette. We 
drag down past the bottom of the menu or beyond either 
side to detach it.

The command, “New Button,” creates a new button on 
the current card or background. When we choose the 
“New Button” command, we switch to the Button tool, 
and a new button is selected.

After we place the new button, we can open the Button 
information dialog. We can name our button, choose the 
style of button, add an icon — or even link to another 
card without writing a single line of script.

If we want to place a button over a graphic and allow the 
graphic to show through, simply create a transparent 
button.  

For example, let’s make the words “Recycling Glass” a 
transparent button.

To do this, we double click on the new button and 
choose “Transparent” from the type menu. 
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O. Position top left of button with top left of 
lettering “Recycling Glass” and size button to 
fit over the words by dragging from just 
inside the lower right-hand corner.

1. Double click on Other Btns  button 
in Demo Helper. 

2. Show other types of buttons. 

3. Click on Browse tool in Tool Palette.

4. Click on button.

P. Select the “Ways to Save the Earth” stack by 
clicking on it.

1.  Choose the Button tool. 

2.  Double-click on the new transparent 
button. 

3.  Click “Tasks. . . ."

Q. The “Go To Destination” task is highlighted. 
Choose “Next Card” as the destination.
Click on “Assign Task."

R. Choose Browse tool and click on words 
covered by the transparent button. 

1.  Close Tool Palette.

S. Double click on Btn Task  in the 
Demo Helper. Show card filled with 
buttons that play movies, sounds and 
speak text.

We can easily size the transparent button so it fits over 
the words “Recycling Glass.” By doing this, the words 
become the button.

HyperCard has many button types that we can choose 
from.

With HyperCard 2.3’s new Button Tasks, we can assign 
actions to buttons that allow navigation through a stack, 
launch other Mac applications, play sounds, make 
pictures disappear and reappear, and play movies.

In this case, we’ll assign a task to our new transparent 
button that will allow us to go to the next card in the 
stack.

Now navigating our stack is as easy as clicking on the 
words “Recycling Glass.” 

As we can see here, button tasks can create buttons that 
play movies and sounds, or speak the text for us.
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Text is a major part of most HyperCard stacks. Text 
fields in stacks are designed to help manage large 
amounts of information.

We’ll put most of the text in fields where we can type 
and edit text easily.

Now we’ll type some text into the field — in this case, 
instructions for using the button.

If we want the field and its text to appear only on one 
card, we put the field on the card layer.

If we want the field to appear on every card in the stack, 
or in a major section of the stack, we put the field in the 
background layer.

1.  Click on button.

2.  Click on “Ways to Save the Earth” stack.

3.  Choose “Prev” from the Go menu .

4.  Choose Field tool from Tools menu.

S. Size field “Card 1” to fit into the space in the 
lower right-hand corner of the Recycling 
Glass card.

T. Select the “Browse” tool and use it to select 
the “Card 1” in the text field.

U. Type “Click the text above to go to the section 
on glass recycling” in the field.

V . Double click on Abt Fields  button in 
the Demo Helper.

1.  Click on button.
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W .Click on Paint Tools  button in the 
Demo Helper.

1.  Click on button.

X . Click on Color Tools  button in the 
Demo Helper.

1.  Click on button.

2.  Click on “Ways to Save the Earth” stack.

Y. Select the Button Tool and double click the 
transparent button over the words “Recycling 
Glass.”

Click on the “Tasks. . .” button and choose 
the “Sound” task. 

Z. Click on “Record. . . .” Click “Record” 
button and say, “Now we’ll see how to 
recycle glass” into the microphone. Click on 
“Stop,” then the “Save” button.

A. Title your sound “Recycling Glass” 

1.  Click “OK.”

2.  Click on "Assign Tasks.” 

B. Choose the Browse tool and use it to 
click on the words “Recycling Glass."

Each card can have its own unique graphics in the card 
layer, plus background graphics it shares with other 
cards.  To create and work with graphics, we can use the 
Paint tools in the Tools menu.

Using Color tools, we can add color to buttons, fields, 
backgrounds, and cards. We can even import and edit 
color PICT graphics.

HyperCard also makes it simple to add audio to our 
stack. 

Here, we’ll add audio using the built-in microphone to 
record a sound.  Then we’ll add a Button Task to play 
the sound when we click on the words “Recycling 
Glass."

This also advances us to the next card.



Optional:  Click on  2  button to 
catch up if needed; this may take up 
to 1 min.

IV. Intermediate Authoring

A. Choose the Field tool, and move the text field 
from the center of Card 2 to the lower right-
hand corner.

Add a QuickTime movie to the stack using 
button tasks.

1.  Choose New Button from the Objects 
menu.

2.  Double click on the New Button.

3.  Change it’s name to “Play Movie” and 
click “Auto Hilite,”  then click on 
“Tasks.”

4.  Choose Movie tasks.

5.  Click “Choose” and select “Globe” 
movie. Set dialog box as shown below:
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Let’s say we want to distribute our “Ways to Save the 
Earth” stack to other users. We decide to expand it with a 
QuickTime movie and then turn it into a stand-alone 
application that doesn’t require HyperCard to run.

We are provided with several QuickTime movies to be 
added. Using the QuickTime movie Button Task, we can 
easily place them in our stack.

Just as we used “Tasks” for easy navigation before, we 
can use it to simplify adding a movie.

All we have to do is choose the movie we wish to play 
and choose our preferences for how we want it to appear 
in our stack. Then click on “Assign Tasks” to set the 
button.



6.  Click “Assign Tasks” button.

7.  Choose Browse Tool.

8.  Click “Play Movie” button to play movie 
on card.

9.  Choose “Quit HyperCard” from the File 
menu.

B. Open QuickEdit by double clicking on its 
icon in the “HyperCard 2.3 Demo” folder on 
your hard drive. 

1.  Choose “Open” from the File menu, 
select  “Glass Recycling Clip 1” from the 
Content folder on the DemoCD. 

2.  Click “Open.”

3.  Click the “Play” button at bottom left of 
movie window to play movie.

4.  Choose “Open” from the File menu, 
select  “Glass Recycling Clip 2” from 
the Content folder on your hard drive. 

5.  Click “Open.”

6.  Drag the second window off to the right 
of the first movie.

7.  Click play button at bottom left of movie 
window to play movie.

8.  Choose “Select All” from Edit menu.

9.  Choose “Copy” from the Edit menu.

10.Click on the window of Clip 1 to select it.

11. Choose “Paste” from Edit menu.

12. Choose “Show Soundtracks” from 
Options menu.

13. Choose “Import Sound File...” from 
File menu.
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Then we can check how our movie plays by clicking the 
“Play” button.  If we’re not satisfied with the way the 
movie is being displayed, we can simply change the 
Button Task to play it differently, or add more movies to 
our Button Task.

HyperCard 2.3 has a suite of multimedia utilities bundled 
with it, including the QuickTime movie editor, 
QuickEdit.  

QuickEdit allows simple cut, copy and paste editing of 
QuickTime movies. In this case, we’re going to paste 
two clips together and add a soundtrack. 

Now that we’ve opened both movies, we will combine 
them together to make one movie.

And we’ll also add a soundtrack.



14. Choose “Glass Recycling Soundtrack” 
from the Content folder on DemoCD.

15.  Click “Open.”

16.  Click the “Play” button at the lower left 
of the active window. 

17.  Click on “Desktop” button.

18.  Choose “Save As…” and name movie 
“Glass Recycling" and click “Save.”

19.  Quit QuickEdit.

20. Double click on 3  button in    
Demo Helper.  

C. Add Glass Recycling movie:

Add a QuickTime movie to the stack using 
button tasks.

1.  Choose New Button from the Objects 
menu.

2.  Double click on the New Button.

3.  Change it’s name to “Glass Recycling” 
and click “Auto Hilite,” then click on 
“Tasks. . .”

4.  Choose the Movie task.
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Now, we’ve created our Academy Award-winning 
movie!

Let’s go back to HyperCard and add our newly edited 
movie to the stack.

We can add the “Glass Recycling” movie to our stack 
easily by assigning it as a Button Task, as we did with 
the “Globe” movie.



5.  Click “Choose” and select “Glass 
Recycling” movie. Set dialog box as 
shown:

6.  Click “Assign Tasks” button.

7.  Move the “Glass Recycling” button to the 
center bottom of the card.

8.  Choose Browse Tool.

9.  Click “Glass Recycling” button to play 
movie on card.

Optional:  

Double click on  4  button to 
catch up if needed.

11.Click 5  button in Demo Helper 
to get ready for next step.
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We need to move the button so we have access to both 
buttons.

So now this edited movie is part of our stack as well.
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D. Choose “Open Animation…” from 
the file menu.

1.  Click “Open” button.

2.  Click “Play” to play animation, then click 
“Stop” with blue bottle showing.

3.  Select blue bottle actor.

4.  Select Path Tool from AddMotion Media 
Controller palette.

5.  Click and drag path point of actor to the 
right.

We can add animation to our stack. Let’s create an 
animation that further illustrates glass recycling.

We can use the animation capabilities to illustrate 
separating glass into bins.

ADDmotion II’s 24-bit color Paint module allows us to 
create animated actors, which are foreground objects — 
and props, which are background objects — using a 
wide variety of special tools and effects.

Using the Media Controller, we select the actor we want 
to animate and place it on the screen.

HyperCard gives us a flexible, path-based animation 
process. Other programs require manually placing 
graphics in different positions over a series of frames.

Using paths like you see here — a line of points or 
screen coordinates — we can easily control how actors 
will move around on screen.
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6.  Choose “Close Animation.”

E. Choose “Link Animation.”

1.  Choose “Button” from list of options.
 

2.  Place button near bottom of card by 
choosing a postion with the cursor and 
clicking once, then click “OK” in the 
button dialog.

3.  Click “Bottles” button to play animation.

4.  Press Command + Period to stop.

HyperCard allows you to create cel-based animations, 
like the bottles, and change the path they follow like 
this...

To make it easier, HyperCard will even install a button 
into our stack to play the animation we’ve just created. 

After we add animation, we look for additional ways to 
improve our stack. We decide to provide another way of 
organizing and accessing information in the stack.

We’ll use HyperCard’s built-in “Power Tools” stack to 
create a simple palette that will allow us to navigate 
backwards and forwards in the stack.



F. Add a palette to the stack to ease navigation.

1.  Double click on the Palette  button in 
the Demo Helper.

2.  Click on “5. Create Palette.”

3.  Install Palette into your “Ways to Save 
Earth” stack by clicking on “6. Install 
Palette.” 

4.  Click on “Desktop” button.

5.  Select  “Ways to Save the Earth” stack 
and click “Open”. 

6.  When you see “Installation Done” dialog, 
click “OK.”

7.  Close “Power Tools” by clicking the close 
box in the upper left hand corner.

8.  Click the forward and backward buttons 
on the Navigator palette to demonstrate 
using the palette.

G. Show Color Paint Tools

1.  Close Navigator palette.

2.  Double click 6  in the Demo 
Helper.

3.  Choose “New Card” from the Edit menu.

4.  Choose “Open Coloring Tools” from 
Color menu.

5.  Choose “Place Picture…” from Items 
menu.

6.  Click the “PICT file…” button. 

7.  Find and open “Earth.pict” inside the
     Content folder on the DemoCD.
 
8.  Grab and place picture in center of card.

9.  Click Paint button on the Color Tools 
Palette.

10. Select “Oval tool” from paint palette.
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We’ll call the Palette “Navigator” and use the art work 
already conveniently created for us.

Now we can install the “Navigator” palette into our 
stack.

Now our simple palette will allow users to easily 
navigate to different sections of the “Ways to Save the 
Earth” stack.

HyperCard now has built-in 24-bit Color Paint Tools. 
Let’s use them to edit an existing picture.

First, we’ll open and place the picture.

Here we’ll use one of the new Paint Tools to change the 
graphic. We’ll add a colored oval to the top of the earth 
to illustrate the widening hole in the ozone layer.



In addition to everything else that HyperCard can do, 
you can extend its usefulness with scripting.

HyperCard comes with a built-in scripting language — 
HyperTalk. In addition, you can use AppleScript and 
any other OSA scripting language. 

Here, we’ll add some HyperTalk to tell our stack to wait 
for a short period and then go to the next card.

To test our new script, we can go back one card and 
then going forward will trigger our script.

Let’s say we want to provide our users access to a 
FileMaker Pro database containing information on local 
recycling centers their areas. 

We can use AppleScript to write a script that imports the 
information from a FileMaker Pro database and places it 
into fields in our stack.

This allows us to automate moving data from the 
FileMaker Pro database to our stack as the data changes. 
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16. Click on “Foreground” and choose a red 
color.

17. Close Paint windows, Clicking “Save” to 
save changes.

18. Close Coloring Tools palette.

19. Click 7  button on Demo Helper. 

H. Add a simple script to this card.

1.  Choose “New Card” from the Edit menu.

2.  Choose “Prev” from the Go menu to go to 
the card with the “Earth” picture on it.

3.  Choose “Card Info…” from the Objects 
menu. Click “Script...” button

4.  Add script as follows:

on openCard
send colorMe
wait 200
go next card

end openCard

5.  Close script window. Click “Yes” to save 
changes

6.  Choose “Prev” from the Go menu, then 
choose “Next” form the Go menu to 
trigger the new “on OpenCard” script

I. Demonstrate AppleScript

1.  Click 8  button in Demo Helper.

2.  Click on “Ways to Save the Earth” stack.

3.  Choose “Button Tool” from the tools 
menu.

4.  Double click “AppleScript” button. Click 
on the “Script...” button in the dialog that 
appears and scroll through to show 
AppleScript.



5.  Close script window.

6.  Choose “Browse Tool” from the tools 
menu.

7.  Click “AppleScript” button.

8.  Quit FileMaker. 

J. Save stack as a stand-alone application.

1.  Choose “Save a Copy...” from File 
menu.

2.  Choose File type: “Application.”

3.  Click “Desktop” button, and click “Save” 
button.

4.  Choose “More Choices” button in the next 
dialog.

5. Click and hold on “Target Machine” to 
show range of choices, then release on 
“Any Macintosh”.

6. Double Click “Next” at bottom of Demo
    Helper to see more buttons.

IV. Advanced Features

A. 3rd Party XCMD’s.

1.  Click on “XCMD’s” button.

B. WorldScript.

1.  Click on “WorldScript” button.
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Notice how all the first names were taken from the 
FileMaker database and copied into the HyperCard stack.

Now that we’ve finished our stack, we want to save it as 
a stand-alone application.

These steps will build a double-clickable application that 
can be shipped without software royalty fees, to users 
who do not have HyperCard software. The application 
can be made to run on PowerPC Macintoshes, older 68K 
Macs, or both!

HyperCard 2.3 has a number of advanced features that 
we won’t demonstrate here, but which enhance it’s 
capabilities as a development tool, including..

A large number of third-party extensions to the 
HyperCard system called  “X Commands” which allow 
you to extend the capabilities of HyperCard.

WorldScript support to ease support for multiple 
languages in a stack.



HyperCard 2.3 Demo Script
Action Script: DO THIS Narration Script: SAY THIS

Copyright 1995 Apple Computer, Inc. Page 18

C. Morph and other parts of MMU.

1.  Click on “Morph” button.

D. Built-in Debugger.

1.  Click on “Debugger” button.

The other parts of the Multimedia utilities include a 16-bit 
sound editor, interactive QuickTime and a paint program 
for creating stand-alone animations.

And HyperCard has built-in script debugging complete 
with tracing and variable watching.


